CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
  Take a third party risk management course for FREE
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Debian » Debian Linux » 2.1 * * * : Security Vulnerabilities

Cpe Name:cpe:2.3:o:debian:debian_linux:2.1:*:*:*:*:*:*:*
Press ESC to close
# CVE ID CWE ID # of Exploits Vulnerability Type(s) Publish Date Update Date Score Gained Access Level Access Complexity Authentication Conf. Integ. Avail.
1 CVE-2001-0886 DoS Exec Code Overflow 2001-12-21 2018-05-03
4.6
None Local Low Not required Partial Partial Partial
Buffer overflow in glob function of glibc allows attackers to cause a denial of service (crash) and possibly execute arbitrary code via a glob pattern that ends in a brace "{" character.
2 CVE-2000-1221 Bypass 2000-01-08 2017-07-11
10.0
None Remote Low Not required Complete Complete Complete
The line printer daemon (lpd) in the lpr package in multiple Linux operating systems authenticates by comparing the reverse-resolved hostname of the local machine to the hostname of the print server as returned by gethostname, which allows remote attackers to bypass intended access controls by modifying the DNS for the attacking IP.
3 CVE-2000-1135 2001-01-09 2017-10-10
4.6
None Local Low Not required Partial Partial Partial
fshd (fsh daemon) in Debian GNU/Linux allows local users to overwrite files of other users via a symlink attack.
4 CVE-2000-0844 264 Exec Code 2000-11-14 2018-10-30
10.0
None Remote Low Not required Complete Complete Complete
Some functions that implement the locale subsystem on Unix do not properly cleanse user-injected format strings, which allows local attackers to execute arbitrary commands via functions such as gettext and catopen.
5 CVE-2000-0607 Overflow +Priv 2000-06-21 2008-09-10
7.2
None Local Low Not required Complete Complete Complete
Buffer overflow in fld program in Kanji on Console (KON) package on Linux may allow local users to gain root privileges via an input file containing long CHARSET_REGISTRY or CHARSET_ENCODING settings.
6 CVE-2000-0606 Overflow +Priv 2000-06-21 2008-09-10
7.2
None Local Low Not required Complete Complete Complete
Buffer overflow in kon program in Kanji on Console (KON) package on Linux may allow local users to gain root privileges via a long -StartupMessage parameter.
7 CVE-2000-0584 Exec Code Overflow 2000-07-02 2018-05-03
10.0
None Remote Low Not required Complete Complete Complete
Buffer overflow in Canna input system allows remote attackers to execute arbitrary commands via an SR_INIT command with a long user name or group name.
8 CVE-2000-0508 DoS 1994-12-19 2017-10-10
5.0
None Remote Low Not required None None Partial
rpc.lockd in Red Hat Linux 6.1 and 6.2 allows remote attackers to cause a denial of service via a malformed request.
9 CVE-2000-0366 1999-12-02 2008-09-10
2.1
None Local Low Not required None Partial None
dump in Debian GNU/Linux 2.1 does not properly restore symlinks, which allows a local user to modify the ownership of arbitrary files.
10 CVE-2000-0289 2000-03-27 2008-09-10
5.0
None Remote Low Not required Partial None None
IP masquerading in Linux 2.2.x allows remote attackers to route UDP packets through the internal interface by modifying the external source IP address and port number to match those of an established connection.
11 CVE-2000-0229 +Priv 2000-03-22 2008-09-10
7.2
None Local Low Not required Complete Complete Complete
gpm-root in the gpm package does not properly drop privileges, which allows local users to gain privileges by starting a utility from gpm-root.
12 CVE-2000-0112 2000-02-02 2016-10-18
7.2
None Local Low Not required Complete Complete Complete
The default installation of Debian GNU/Linux uses an insecure Master Boot Record (MBR) which allows a local user to boot from a floppy disk during the installation.
13 CVE-2000-0107 2000-02-01 2008-09-10
7.2
None Local Low Not required Complete Complete Complete
Linux apcd program allows local attackers to modify arbitrary files via a symlink attack.
14 CVE-2000-0076 1999-12-30 2016-10-18
2.1
None Local Low Not required None Partial None
nviboot boot script in the Debian nvi package allows local users to delete files via malformed entries in vi.recover.
15 CVE-1999-1496 1999-06-08 2017-12-19
2.1
None Local Low Not required Partial None None
Sudo 1.5 in Debian Linux 2.1 and Red Hat 6.0 allows local users to determine the existence of arbitrary files by attempting to execute the target filename as a program, which generates a different error message when the file does not exist.
16 CVE-1999-1276 +Priv 1998-12-07 2017-10-10
7.2
None Local Low Not required Complete Complete Complete
fte-console in the fte package before 0.46b-4.1 does not drop root privileges, which allows local users to gain root access via the virtual console device.
17 CVE-1999-0986 DoS 1999-12-08 2008-09-09
5.0
None Remote Low Not required None None Partial
The ping command in Linux 2.0.3x allows local users to cause a denial of service by sending large packets with the -R (record route) option.
18 CVE-1999-0978 Exec Code 1999-12-09 2008-09-09
7.5
None Remote Low Not required Partial Partial Partial
htdig allows remote attackers to execute commands via filenames with shell metacharacters.
19 CVE-1999-0939 DoS 1999-08-26 2008-09-09
5.0
None Remote Low Not required None None Partial
Denial of service in Debian IRC Epic/epic4 client via a long string.
20 CVE-1999-0872 Overflow 1999-08-25 2008-09-09
7.2
None Local Low Not required Complete Complete Complete
Buffer overflow in Vixie cron allows local users to gain root access via a long MAILTO environment variable in a crontab file.
21 CVE-1999-0832 Exec Code Overflow 1999-11-09 2008-09-09
10.0
None Remote Low Not required Complete Complete Complete
Buffer overflow in NFS server on Linux allows attackers to execute commands via a long pathname.
22 CVE-1999-0804 DoS 1999-06-01 2008-09-09
5.0
None Remote Low Not required None None Partial
Denial of service in Linux 2.2.x kernels via malformed ICMP packets containing unusual types, codes, and IP header lengths.
23 CVE-1999-0769 1999-08-25 2008-09-09
7.2
None Local Low Not required Complete Complete Complete
Vixie Cron on Linux systems allows local users to set parameters of sendmail commands via the MAILTO environmental variable.
24 CVE-1999-0742 +Priv 1999-06-22 2008-09-09
5.0
None Remote Low Not required Partial None None
The Debian mailman package uses weak authentication, which allows attackers to gain privileges.
25 CVE-1999-0434 DoS +Priv 1999-03-30 2008-09-09
7.5
None Remote Low Not required Partial Partial Partial
XFree86 xfs command is vulnerable to a symlink attack, allowing local users to create files in restricted directories, possibly allowing them to gain privileges or cause a denial of service.
Total number of vulnerabilities : 25   Page : 1 (This Page)
CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.