CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
  Take a third party risk management course for FREE
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2019-12402

The file name encoding algorithm used internally in Apache Commons Compress 1.15 to 1.18 can get into an infinite loop when faced with specially crafted inputs. This can lead to a denial of service attack if an attacker can choose the file names inside of an archive created by Compress.
Publish Date : 2019-08-30 Last Update Date : 2022-05-14
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
5.0
Confidentiality Impact None (There is no impact to the confidentiality of the system.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Denial Of Service
CWE ID 835

- Products Affected By CVE-2019-12402

# Product Type Vendor Product Version Update Edition Language
1 Application Apache Commons Compress * * * * Version Details Vulnerabilities
2 OS Fedoraproject Fedora 30 * * * Version Details Vulnerabilities
3 OS Fedoraproject Fedora 31 * * * Version Details Vulnerabilities
4 Application Oracle Banking Payments * * * * Version Details Vulnerabilities
5 Application Oracle Banking Platform 2.6.2 * * * Version Details Vulnerabilities
6 Application Oracle Banking Platform 2.7.0 * * * Version Details Vulnerabilities
7 Application Oracle Banking Platform 2.8.0 * * * Version Details Vulnerabilities
8 Application Oracle Banking Platform 2.9.0 * * * Version Details Vulnerabilities
9 Application Oracle Communications Element Manager * * * * Version Details Vulnerabilities
10 Application Oracle Communications Ip Service Activator 7.3.0 * * * Version Details Vulnerabilities
11 Application Oracle Communications Ip Service Activator 7.4.0 * * * Version Details Vulnerabilities
12 Application Oracle Communications Session Report Manager * * * * Version Details Vulnerabilities
13 Application Oracle Communications Session Route Manager * * * * Version Details Vulnerabilities
14 Application Oracle Customer Management And Segmentation Foundation 18.0 * * * Version Details Vulnerabilities
15 Application Oracle Essbase 21.2 * * * Version Details Vulnerabilities
16 Application Oracle Flexcube Investor Servicing 12.1.0 * * * Version Details Vulnerabilities
17 Application Oracle Flexcube Investor Servicing 12.3.0 * * * Version Details Vulnerabilities
18 Application Oracle Flexcube Investor Servicing 12.4.0 * * * Version Details Vulnerabilities
19 Application Oracle Flexcube Investor Servicing 14.0.0 * * * Version Details Vulnerabilities
20 Application Oracle Flexcube Investor Servicing 14.1.0 * * * Version Details Vulnerabilities
21 Application Oracle Flexcube Private Banking 12.0.0 * * * Version Details Vulnerabilities
22 Application Oracle Flexcube Private Banking 12.1.0 * * * Version Details Vulnerabilities
23 Application Oracle Hyperion Infrastructure Technology 11.1.2.4 * * * Version Details Vulnerabilities
24 Application Oracle Jdeveloper 12.2.1.4.0 * * * Version Details Vulnerabilities
25 Application Oracle Peoplesoft Enterprise Pt Peopletools 8.56 * * * Version Details Vulnerabilities
26 Application Oracle Peoplesoft Enterprise Pt Peopletools 8.57 * * * Version Details Vulnerabilities
27 Application Oracle Peoplesoft Enterprise Pt Peopletools 8.58 * * * Version Details Vulnerabilities
28 Application Oracle Primavera Gateway * * * * Version Details Vulnerabilities
29 Application Oracle Primavera Gateway 19.12.0 * * * Version Details Vulnerabilities
30 Application Oracle Retail Integration Bus 15.0 * * * Version Details Vulnerabilities
31 Application Oracle Retail Integration Bus 16.0 * * * Version Details Vulnerabilities
32 Application Oracle Retail Xstore Point Of Service 15.0 * * * Version Details Vulnerabilities
33 Application Oracle Retail Xstore Point Of Service 16.0 * * * Version Details Vulnerabilities
34 Application Oracle Retail Xstore Point Of Service 17.0 * * * Version Details Vulnerabilities
35 Application Oracle Retail Xstore Point Of Service 18.0 * * * Version Details Vulnerabilities
36 Application Oracle Retail Xstore Point Of Service 19.0 * * * Version Details Vulnerabilities
37 Application Oracle Webcenter Portal 12.2.1.3.0 * * * Version Details Vulnerabilities
38 Application Oracle Webcenter Portal 12.2.1.4.0 * * * Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Apache Commons Compress 1
Fedoraproject Fedora 2
Oracle Banking Payments 1
Oracle Banking Platform 4
Oracle Communications Element Manager 1
Oracle Communications Ip Service Activator 2
Oracle Communications Session Report Manager 1
Oracle Communications Session Route Manager 1
Oracle Customer Management And Segmentation Foundation 1
Oracle Essbase 1
Oracle Flexcube Investor Servicing 5
Oracle Flexcube Private Banking 2
Oracle Hyperion Infrastructure Technology 1
Oracle Jdeveloper 1
Oracle Peoplesoft Enterprise Pt Peopletools 3
Oracle Primavera Gateway 2
Oracle Retail Integration Bus 2
Oracle Retail Xstore Point Of Service 5
Oracle Webcenter Portal 2

- References For CVE-2019-12402

https://www.oracle.com/security-alerts/cpuapr2022.html
https://www.oracle.com/security-alerts/cpuoct2020.html
https://lists.apache.org/thread.html/54cc4e9fa6b24520135f6fa4724dfb3465bc14703c7dc7e52353a0ea@%3Ccommits.creadur.apache.org%3E
MLIST [creadur-commits] 20191022 [creadur-rat] branch master updated: RAT-258: Update to latest commons-compress to fix CVE-2019-12402
https://www.oracle.com/security-alerts/cpuoct2021.html
https://www.oracle.com/security-alerts/cpuApr2021.html
https://www.oracle.com//security-alerts/cpujul2021.html
N/A N/A
https://lists.apache.org/thread.html/r5caf4fcb69d2749225391e61db7216282955204849ba94f83afe011f@%3Cissues.flink.apache.org%3E
MLIST [flink-issues] 20200306 [GitHub] [flink] nielsbasjes opened a new pull request #11333: [FLINK-14121] Update commons-compress because of CVE-2019-12402
https://lists.apache.org/thread.html/rcc35ab6be300365de5ff9587e0479d10d7d7c79070921837e3693162@%3Cissues.flink.apache.org%3E
MLIST [flink-issues] 20200306 [GitHub] [flink] flinkbot edited a comment on issue #11333: [FLINK-14121] Update commons-compress because of CVE-2019-12402
https://lists.apache.org/thread.html/re13bd219dd4b651134f6357f12bd07a0344eea7518c577bbdd185265@%3Cissues.flink.apache.org%3E
MLIST [flink-issues] 20200306 [GitHub] [flink] flinkbot commented on issue #11333: [FLINK-14121] Update commons-compress because of CVE-2019-12402
https://lists.apache.org/thread.html/r5103b1c9242c0f812ac96e524344144402cbff9b6e078d1557bc7b1e@%3Cissues.flink.apache.org%3E
MLIST [flink-issues] 20200310 [GitHub] [flink] GJL commented on issue #11333: [FLINK-14121] Update commons-compress because of CVE-2019-12402
https://lists.apache.org/thread.html/r05cf37c1e1e662e968cfece1102fcd50fe207181fdbf2c30aadfafd3@%3Cissues.flink.apache.org%3E
MLIST [flink-issues] 20200311 [GitHub] [flink] GJL commented on issue #11333: [FLINK-14121] Update commons-compress because of CVE-2019-12402
https://lists.apache.org/thread.html/r590c15cebee9b8e757e2f738127a9a71e48ede647a3044c504e050a4@%3Cissues.flink.apache.org%3E
MLIST [flink-issues] 20200311 [GitHub] [flink] nielsbasjes commented on issue #11333: [FLINK-14121] Update commons-compress because of CVE-2019-12402
https://lists.apache.org/thread.html/rdebc1830d6c09c11d5a4804ca26769dbd292d17d361c61dea50915f0@%3Cissues.flink.apache.org%3E
MLIST [flink-issues] 20200311 [GitHub] [flink] flinkbot edited a comment on issue #11333: [FLINK-14121] Update commons-compress because of CVE-2019-12402
https://lists.apache.org/thread.html/rd3f99d732baed459b425fb0a9e9e14f7843c9459b12037e4a9d753b5@%3Cissues.flink.apache.org%3E
MLIST [flink-issues] 20200311 [GitHub] [flink] nielsbasjes edited a comment on issue #11333: [FLINK-14121] Update commons-compress because of CVE-2019-12402
https://www.oracle.com/security-alerts/cpuapr2020.html
N/A N/A
https://www.oracle.com/security-alerts/cpujul2020.html
https://lists.apache.org/thread.html/r7af60fbd8b2350d49d14e53a3ab2801998b9d1af2d6fcac60b060a53@%3Cdev.brooklyn.apache.org%3E
MLIST [brooklyn-dev] 20200403 [GitHub] [brooklyn-server] nakomis opened a new pull request #1089: Bumps commons-compress version
https://lists.apache.org/thread.html/rf5230a049d989dbfdd404b4320a265dceeeba459a4d04ec21873bd55@%3Csolr-user.lucene.apache.org%3E
MLIST [lucene-solr-user] 20200320 Re: CVEs (vulnerabilities) that apply to Solr 8.4.1
https://lists.apache.org/thread.html/r204ba2a9ea750f38d789d2bb429cc0925ad6133deea7cbc3001d96b5@%3Csolr-user.lucene.apache.org%3E
MLIST [lucene-solr-user] 20200320 CVEs (vulnerabilities) that apply to Solr 8.4.1
https://lists.apache.org/thread.html/r4363c994c8bca033569a98da9218cc0c62bb695c1e47a98e5084e5a0@%3Cissues.flink.apache.org%3E
MLIST [flink-issues] 20200313 [GitHub] [flink] GJL closed pull request #11333: [FLINK-14121] Update commons-compress because of CVE-2019-12402
https://lists.apache.org/thread.html/r972f82d821b805d04602976a9736c01b6bf218cfe0c3f48b472db488@%3Cissues.flink.apache.org%3E
MLIST [flink-issues] 20200313 [GitHub] [flink] zentol commented on issue #11333: [FLINK-14121] Update commons-compress because of CVE-2019-12402
https://lists.apache.org/thread.html/r233267e24519bacd0f9fb9f61a1287cb9f4bcb6e75d83f34f405c521@%3Cissues.flink.apache.org%3E
MLIST [flink-issues] 20200312 [GitHub] [flink] GJL commented on issue #11333: [FLINK-14121] Update commons-compress because of CVE-2019-12402
https://lists.apache.org/thread.html/308cc15f1f1dc53e97046fddbac240e6cd16de89a2746cf257be7f5b@%3Cdev.commons.apache.org%3E
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/WZB3GB7YXIOUKIOQ27VTIP6KKGJJ3CKL/
FEDORA FEDORA-2019-da0eac1eb6
https://lists.apache.org/thread.html/r21d64797914001119d2fc766b88c6da181dc2308d20f14e7a7f46117@%3Cissues.flink.apache.org%3E
MLIST [flink-issues] 20200312 [GitHub] [flink] zentol commented on issue #11333: [FLINK-14121] Update commons-compress because of CVE-2019-12402
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/QLJIK2AUOZOWXR3S5XXBUNMOF3RTHTI7/
FEDORA FEDORA-2019-c96a8d12b0
https://www.oracle.com/security-alerts/cpujan2021.html
https://lists.apache.org/thread.html/r25422df9ad22fec56d9eeca3ab8bd6d66365e9f6bfe311b64730edf5@%3Cissues.flink.apache.org%3E
MLIST [flink-issues] 20200313 [GitHub] [flink] GJL commented on issue #11333: [FLINK-14121] Update commons-compress because of CVE-2019-12402
https://lists.apache.org/thread.html/9317fd092b257a0815434b116a8af8daea6e920b6673f4fd5583d5fe@%3Ccommits.druid.apache.org%3E
MLIST [druid-commits] 20191115 [GitHub] [incubator-druid] ccaominh opened a new pull request #8878: Address security vulnerabilities

- Metasploit Modules Related To CVE-2019-12402

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.