CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
  Take a third party risk management course for FREE
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2015-3456

The Floppy Disk Controller (FDC) in QEMU, as used in Xen 4.5.x and earlier and KVM, allows local guest users to cause a denial of service (out-of-bounds write and guest crash) or possibly execute arbitrary code via the (1) FD_CMD_READ_ID, (2) FD_CMD_DRIVE_SPECIFICATION_COMMAND, or other unspecified commands, aka VENOM.
Publish Date : 2015-05-13 Last Update Date : 2021-11-17
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
7.7
Confidentiality Impact Complete (There is total information disclosure, resulting in all system files being revealed.)
Integrity Impact Complete (There is a total compromise of system integrity. There is a complete loss of system protection, resulting in the entire system being compromised.)
Availability Impact Complete (There is a total shutdown of the affected resource. The attacker can render the resource completely unavailable.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication ???
Gained Access None
Vulnerability Type(s) Denial Of ServiceExecute CodeOverflow
CWE ID 119

- Related OVAL Definitions

Title Definition Id Class Family
CESA-2015:0998 -- centos 6 qemu-kvm,qemu-guest-agent oval:org.mitre.oval:def:28912 unix
CESA-2015:0999 -- centos 7 qemu-kvm,libcacard oval:org.mitre.oval:def:28600 unix
CESA-2015:1002 -- centos 5 xen oval:org.mitre.oval:def:28937 unix
CESA-2015:1003 -- centos 5 kvm oval:org.mitre.oval:def:28198 unix
DSA-3259-1 qemu -- qemu oval:org.mitre.oval:def:29063 unix
ELSA-2015-0998 -- Oracle qemu-kvm_qemu-guest-agent oval:org.mitre.oval:def:29004 unix
ELSA-2015-0999 -- Oracle qemu-kvm oval:org.mitre.oval:def:28893 unix
ELSA-2015-1002 -- Oracle xen oval:org.mitre.oval:def:28974 unix
ELSA-2015-1003 -- Oracle kvm-83 oval:org.mitre.oval:def:28949 unix
RHSA-2015:0998-01 -- Redhat qemu-kvm, qemu-guest-agent oval:org.mitre.oval:def:28702 unix
RHSA-2015:0998: qemu-kvm security update (Important) oval:com.redhat.rhsa:def:20150998 unix
RHSA-2015:0999-01 -- Redhat qemu-kvm, libcacard oval:org.mitre.oval:def:28106 unix
RHSA-2015:0999: qemu-kvm security update (Important) oval:com.redhat.rhsa:def:20150999 unix
RHSA-2015:1002-01 -- Redhat xen oval:org.mitre.oval:def:28539 unix
RHSA-2015:1002: xen security update (Important) oval:com.redhat.rhsa:def:20151002 unix
RHSA-2015:1003: kvm security update (Important) oval:com.redhat.rhsa:def:20151003 unix
USN-2608-1 -- qemu vulnerabilities oval:org.mitre.oval:def:28687 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2015-3456

# Product Type Vendor Product Version Update Edition Language
1 Application Qemu Qemu * * * * Version Details Vulnerabilities
2 OS Redhat Enterprise Linux 5 * * * Version Details Vulnerabilities
3 OS Redhat Enterprise Linux 6.0 * * * Version Details Vulnerabilities
4 OS Redhat Enterprise Linux 7.0 * * * Version Details Vulnerabilities
5 Application Redhat Enterprise Virtualization 3.0 * * * Version Details Vulnerabilities
6 Application Redhat Openstack 4.0 * * * Version Details Vulnerabilities
7 Application Redhat Openstack 5.0 * * * Version Details Vulnerabilities
8 Application Redhat Openstack 6.0 * * * Version Details Vulnerabilities
9 Application Redhat Openstack 7.0 * * * Version Details Vulnerabilities
10 OS XEN XEN 4.5.0 * * * Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Qemu Qemu 1
Redhat Enterprise Linux 3
Redhat Enterprise Virtualization 1
Redhat Openstack 4
XEN XEN 1

- References For CVE-2015-3456

http://support.citrix.com/article/CTX201078 CONFIRM
https://security.gentoo.org/glsa/201604-03
GENTOO GLSA-201604-03
http://git.qemu.org/?p=qemu.git;a=commitdiff;h=e907746266721f305d67bc0718795fedee2e824c CONFIRM
http://www.securitytracker.com/id/1032917
SECTRACK 1032917
http://www.securitytracker.com/id/1032306
SECTRACK 1032306
http://www.debian.org/security/2015/dsa-3262
DEBIAN DSA-3262
http://rhn.redhat.com/errata/RHSA-2015-1011.html
REDHAT RHSA-2015:1011
http://lists.opensuse.org/opensuse-security-announce/2015-05/msg00018.html
SUSE SUSE-SU-2015:0923
http://lists.opensuse.org/opensuse-security-announce/2015-05/msg00014.html
SUSE openSUSE-SU-2015:0894
http://lists.opensuse.org/opensuse-security-announce/2015-05/msg00013.html
SUSE openSUSE-SU-2015:0893
https://security.gentoo.org/glsa/201612-27
GENTOO GLSA-201612-27
https://security.gentoo.org/glsa/201602-01
GENTOO GLSA-201602-01
http://lists.opensuse.org/opensuse-security-announce/2015-06/msg00001.html
SUSE openSUSE-SU-2015:0983
https://kb.juniper.net/JSA10783 CONFIRM
http://lists.opensuse.org/opensuse-security-announce/2015-05/msg00009.html
SUSE SUSE-SU-2015:0889
https://www.arista.com/en/support/advisories-notices/security-advisories/1128-security-advisory-10
http://www.securitytracker.com/id/1032311
SECTRACK 1032311
https://www.exploit-db.com/exploits/37053/
EXPLOIT-DB 37053
http://www.fortiguard.com/advisory/2015-05-19-cve-2015-3456-venom-vulnerability CONFIRM
http://lists.opensuse.org/opensuse-updates/2015-08/msg00021.html
SUSE openSUSE-SU-2015:1400
https://securityblog.redhat.com/2015/05/13/venom-dont-get-bitten/ CONFIRM
http://www1.huawei.com/en/security/psirt/security-bulletins/security-advisories/hw-438937.htm CONFIRM
http://kb.juniper.net/InfoCenter/index?page=content&id=JSA10693 CONFIRM
https://bto.bluecoat.com/security-advisory/sa95 CONFIRM
http://rhn.redhat.com/errata/RHSA-2015-1002.html
REDHAT RHSA-2015:1002
http://rhn.redhat.com/errata/RHSA-2015-1000.html
REDHAT RHSA-2015:1000
http://rhn.redhat.com/errata/RHSA-2015-0999.html
REDHAT RHSA-2015:0999
http://rhn.redhat.com/errata/RHSA-2015-0998.html
REDHAT RHSA-2015:0998
http://marc.info/?l=bugtraq&m=143387998230996&w=2
HP HPSBMU03349
https://support.lenovo.com/us/en/product_security/venom CONFIRM
http://www.debian.org/security/2015/dsa-3259
DEBIAN DSA-3259
http://www.ubuntu.com/usn/USN-2608-1
UBUNTU USN-2608-1
http://lists.opensuse.org/opensuse-security-announce/2015-05/msg00042.html
SUSE SUSE-SU-2015:0896
http://www.oracle.com/technetwork/topics/security/cpujul2015-2367936.html CONFIRM
http://marc.info/?l=bugtraq&m=143229451215900&w=2
HP SSRT102076
http://www.securityfocus.com/bid/74640
BID 74640 QEMU 'hw/block/fdc.c' VENOM Remote Memory Corruption Vulnerability Release Date:2017-04-17
https://kc.mcafee.com/corporate/index?page=content&id=SB10118 CONFIRM
http://rhn.redhat.com/errata/RHSA-2015-1004.html
REDHAT RHSA-2015:1004
https://www.suse.com/security/cve/CVE-2015-3456.html CONFIRM
http://lists.opensuse.org/opensuse-security-announce/2015-05/msg00019.html
SUSE SUSE-SU-2015:0927
http://www.debian.org/security/2015/dsa-3274
DEBIAN DSA-3274
http://lists.opensuse.org/opensuse-security-announce/2015-05/msg00021.html
SUSE SUSE-SU-2015:0929
http://venom.crowdstrike.com/
http://rhn.redhat.com/errata/RHSA-2015-1003.html
REDHAT RHSA-2015:1003
https://access.redhat.com/articles/1444903 CONFIRM
http://rhn.redhat.com/errata/RHSA-2015-1001.html
REDHAT RHSA-2015:1001
http://lists.fedoraproject.org/pipermail/package-announce/2015-May/158072.html
FEDORA FEDORA-2015-8249
http://xenbits.xen.org/xsa/advisory-133.html CONFIRM

- Metasploit Modules Related To CVE-2015-3456

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.