CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
  Take a third party risk management course for FREE
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2014-7169

GNU Bash through 4.3 bash43-025 processes trailing strings after certain malformed function definitions in the values of environment variables, which allows remote attackers to write to files or possibly have unknown other impact via a crafted environment, as demonstrated by vectors involving the ForceCommand feature in OpenSSH sshd, the mod_cgi and mod_cgid modules in the Apache HTTP Server, scripts executed by unspecified DHCP clients, and other situations in which setting the environment occurs across a privilege boundary from Bash execution. NOTE: this vulnerability exists because of an incomplete fix for CVE-2014-6271.
Publish Date : 2014-09-25 Last Update Date : 2021-11-17
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
10.0
Confidentiality Impact Complete (There is total information disclosure, resulting in all system files being revealed.)
Integrity Impact Complete (There is a total compromise of system integrity. There is a complete loss of system protection, resulting in the entire system being compromised.)
Availability Impact Complete (There is a total shutdown of the affected resource. The attacker can render the resource completely unavailable.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Execute Code
CWE ID 78

- Related OVAL Definitions

Title Definition Id Class Family
DSA-3035-1 bash - security update oval:org.mitre.oval:def:26665 unix
ELSA-2014-1306 -- bash security update (Important) oval:org.mitre.oval:def:27118 unix
ELSA-2014-3075 -- bash security update (Critical) oval:org.mitre.oval:def:26555 unix
ELSA-2014-3076 -- bash security update (Critical) oval:org.mitre.oval:def:26615 unix
ELSA-2014-3077 -- bash security update (Critical) oval:org.mitre.oval:def:26614 unix
ELSA-2014-3078 -- bash security update (Critical) oval:org.mitre.oval:def:26712 unix
ELSA-2014-3079 -- bash security update (Important) oval:org.mitre.oval:def:26928 unix
RHSA-2014:1306: bash security update (Important) oval:com.redhat.rhsa:def:20141306 unix
RHSA-2014:1306: bash security update (Important) oval:org.mitre.oval:def:26589 unix
SUSE-SU-2014:1259-1 -- bash (important) oval:org.mitre.oval:def:27981 unix
SUSE-SU-2014:1247-1 -- Security update for bash oval:org.mitre.oval:def:26631 unix
USN-2363-1 -- bash vulnerability oval:org.mitre.oval:def:26290 unix
USN-2363-2 -- bash vulnerability oval:org.mitre.oval:def:26745 unix
VMware product updates address critical Bash security vulnerabilities oval:org.mitre.oval:def:28062 unix
Vulnerability affecting GNU Bash oval:org.mitre.oval:def:26447 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2014-7169

# Product Type Vendor Product Version Update Edition Language
1 Application GNU Bash 1.14.0 * * * Version Details Vulnerabilities
2 Application GNU Bash 1.14.1 * * * Version Details Vulnerabilities
3 Application GNU Bash 1.14.2 * * * Version Details Vulnerabilities
4 Application GNU Bash 1.14.3 * * * Version Details Vulnerabilities
5 Application GNU Bash 1.14.4 * * * Version Details Vulnerabilities
6 Application GNU Bash 1.14.5 * * * Version Details Vulnerabilities
7 Application GNU Bash 1.14.6 * * * Version Details Vulnerabilities
8 Application GNU Bash 1.14.7 * * * Version Details Vulnerabilities
9 Application GNU Bash 2.0 * * * Version Details Vulnerabilities
10 Application GNU Bash 2.01 * * * Version Details Vulnerabilities
11 Application GNU Bash 2.01.1 * * * Version Details Vulnerabilities
12 Application GNU Bash 2.02 * * * Version Details Vulnerabilities
13 Application GNU Bash 2.02.1 * * * Version Details Vulnerabilities
14 Application GNU Bash 2.03 * * * Version Details Vulnerabilities
15 Application GNU Bash 2.04 * * * Version Details Vulnerabilities
16 Application GNU Bash 2.05 * * * Version Details Vulnerabilities
17 Application GNU Bash 2.05 A * * Version Details Vulnerabilities
18 Application GNU Bash 2.05 B * * Version Details Vulnerabilities
19 Application GNU Bash 3.0 * * * Version Details Vulnerabilities
20 Application GNU Bash 3.0.16 * * * Version Details Vulnerabilities
21 Application GNU Bash 3.1 * * * Version Details Vulnerabilities
22 Application GNU Bash 3.2 * * * Version Details Vulnerabilities
23 Application GNU Bash 3.2.48 * * * Version Details Vulnerabilities
24 Application GNU Bash 4.0 * * * Version Details Vulnerabilities
25 Application GNU Bash 4.0 RC1 * * Version Details Vulnerabilities
26 Application GNU Bash 4.1 * * * Version Details Vulnerabilities
27 Application GNU Bash 4.2 * * * Version Details Vulnerabilities
28 Application GNU Bash 4.3 * * * Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
GNU Bash 28

- References For CVE-2014-7169

https://www.exploit-db.com/exploits/34879/
EXPLOIT-DB 34879
https://support.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-c04518183 CONFIRM
http://marc.info/?l=bugtraq&m=141383196021590&w=2
HP HPSBST03129
https://www.arista.com/en/support/advisories-notices/security-advisories/1008-security-advisory-0006
http://www.securityfocus.com/archive/1/533593/100/0/threaded
BUGTRAQ 20141001 NEW VMSA-2014-0010 - VMware product updates address critical Bash security vulnerabilities
https://help.ecostruxureit.com/display/public/UADCO8x/StruxureWare+Data+Center+Operation+Software+Vulnerability+Fixes CONFIRM
https://support.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-c04497075 CONFIRM
http://secunia.com/advisories/59272
SECUNIA 59272
https://access.redhat.com/node/1200223 CONFIRM
http://secunia.com/advisories/62228
SECUNIA 62228
http://secunia.com/advisories/60044
SECUNIA 60044
http://www-01.ibm.com/support/docview.wss?uid=swg21686445 CONFIRM
http://www-01.ibm.com/support/docview.wss?uid=swg21687079 CONFIRM
http://www-01.ibm.com/support/docview.wss?uid=isg3T1021361 CONFIRM
https://kc.mcafee.com/corporate/index?page=content&id=SB10085 CONFIRM
http://secunia.com/advisories/61188
SECUNIA 61188
http://marc.info/?l=bugtraq&m=141345648114150&w=2
HP HPSBHF03125
http://archives.neohapsis.com/archives/bugtraq/2014-10/0101.html
APPLE APPLE-SA-2014-10-16-1
http://marc.info/?l=bugtraq&m=141330425327438&w=2
HP HPSBMU03133
http://marc.info/?l=bugtraq&m=141330468527613&w=2
HP HPSBGN03138
http://secunia.com/advisories/60034
SECUNIA 60034
http://secunia.com/advisories/61816
SECUNIA 61816
http://www-01.ibm.com/support/docview.wss?uid=ssg1S1004898 CONFIRM
http://www-01.ibm.com/support/docview.wss?uid=swg21685733 CONFIRM
http://secunia.com/advisories/61442
SECUNIA 61442
https://support.citrix.com/article/CTX200223 CONFIRM
http://secunia.com/advisories/60055
SECUNIA 60055
http://www-01.ibm.com/support/docview.wss?uid=ssg1S1004897 CONFIRM
http://secunia.com/advisories/61780
SECUNIA 61780
http://www-01.ibm.com/support/docview.wss?uid=ssg1S1004915 CONFIRM
http://secunia.com/advisories/60193
SECUNIA 60193
http://www-01.ibm.com/support/docview.wss?uid=swg21685604 CONFIRM
http://secunia.com/advisories/61855
SECUNIA 61855
http://secunia.com/advisories/60325
SECUNIA 60325
http://www-01.ibm.com/support/docview.wss?uid=swg21686131 CONFIRM
http://www.mandriva.com/security/advisories?name=MDVSA-2015:164
MANDRIVA MDVSA-2015:164
http://marc.info/?l=bugtraq&m=141879528318582&w=2
HP HPSBMU03217
http://marc.info/?l=bugtraq&m=142118135300698&w=2
HP SSRT101868
http://marc.info/?l=bugtraq&m=142721162228379&w=2
HP SSRT101819
http://marc.info/?l=bugtraq&m=142805027510172&w=2
HP HPSBST03195
http://advisories.mageia.org/MGASA-2014-0393.html CONFIRM
http://marc.info/?l=bugtraq&m=142113462216480&w=2
HP SSRT101711
http://marc.info/?l=bugtraq&m=142358026505815&w=2
HP HPSBMU03245
http://marc.info/?l=bugtraq&m=142358078406056&w=2
HP HPSBMU03246
http://secunia.com/advisories/62312
SECUNIA 62312
http://secunia.com/advisories/62343
SECUNIA 62343
http://marc.info/?l=bugtraq&m=141694386919794&w=2
HP HPSBST03148
http://marc.info/?l=bugtraq&m=141585637922673&w=2
HP HPSBMU03182
http://marc.info/?l=bugtraq&m=141450491804793&w=2
HP HPSBST03157
http://marc.info/?l=bugtraq&m=141577137423233&w=2
HP HPSBMU03165
http://marc.info/?l=bugtraq&m=141577297623641&w=2
HP HPSBST03154
http://secunia.com/advisories/61700
SECUNIA 61700
http://secunia.com/advisories/61618
SECUNIA 61618
http://linux.oracle.com/errata/ELSA-2014-1306.html CONFIRM
http://linux.oracle.com/errata/ELSA-2014-3077.html CONFIRM
http://secunia.com/advisories/61676
SECUNIA 61676
http://www.novell.com/support/kb/doc.php?id=7015701 CONFIRM
http://marc.info/?l=bugtraq&m=141576728022234&w=2
HP HPSBST03155
http://marc.info/?l=bugtraq&m=141577241923505&w=2
HP HPSBST03181
http://secunia.com/advisories/61873
SECUNIA 61873
http://secunia.com/advisories/60433
SECUNIA 60433
http://marc.info/?l=bugtraq&m=141383244821813&w=2
HP HPSBGN03142
http://lists.opensuse.org/opensuse-updates/2014-10/msg00025.html
SUSE openSUSE-SU-2014:1310
http://www.novell.com/support/kb/doc.php?id=7015721 CONFIRM
http://secunia.com/advisories/61503
SECUNIA 61503
http://secunia.com/advisories/61711
SECUNIA 61711
http://secunia.com/advisories/61715
SECUNIA 61715
http://marc.info/?l=bugtraq&m=141383138121313&w=2
HP HPSBST03131
http://marc.info/?l=bugtraq&m=141383465822787&w=2
HP HPSBHF03145
http://www-01.ibm.com/support/docview.wss?uid=swg21686447 CONFIRM
http://jvndb.jvn.jp/jvndb/JVNDB-2014-000126
JVNDB JVNDB-2014-000126
http://jvn.jp/en/jp/JVN55667175/index.html
JVN JVN#55667175
http://marc.info/?l=bugtraq&m=141383081521087&w=2
HP HPSBMU03144
http://secunia.com/advisories/60063
SECUNIA 60063
http://marc.info/?l=bugtraq&m=141383304022067&w=2
HP HPSBGN03141
https://access.redhat.com/articles/1200223 CONFIRM
http://www-01.ibm.com/support/docview.wss?uid=swg21686494 CONFIRM
http://www.qnap.com/i/en/support/con_show.php?cid=61 CONFIRM
http://marc.info/?l=bugtraq&m=141383026420882&w=2
HP HPSBMU03143
http://marc.info/?l=bugtraq&m=141383353622268&w=2
HP HPSBHF03146
http://rhn.redhat.com/errata/RHSA-2014-1354.html
REDHAT RHSA-2014:1354
http://lists.opensuse.org/opensuse-updates/2014-10/msg00023.html
SUSE openSUSE-SU-2014:1308
https://supportcenter.checkpoint.com/supportcenter/portal?eventSubmit_doGoviewsolutiondetails=&solutionid=sk102673&src=securityAlerts CONFIRM
http://secunia.com/advisories/61291
SECUNIA 61291
http://www-01.ibm.com/support/docview.wss?uid=swg21686246 CONFIRM
http://secunia.com/advisories/60024
SECUNIA 60024
http://secunia.com/advisories/61550
SECUNIA 61550
http://secunia.com/advisories/61065
SECUNIA 61065
http://secunia.com/advisories/58200
SECUNIA 58200
http://secunia.com/advisories/61857
SECUNIA 61857
http://secunia.com/advisories/61471
SECUNIA 61471
http://secunia.com/advisories/61328
SECUNIA 61328
http://www-01.ibm.com/support/docview.wss?uid=swg21685541 CONFIRM
https://support.f5.com/kb/en-us/solutions/public/15000/600/sol15629.html CONFIRM
http://www-947.ibm.com/support/entry/portal/docdisplay?lndocid=MIGR-5096315 CONFIRM
http://secunia.com/advisories/61129
SECUNIA 61129
http://www-01.ibm.com/support/docview.wss?uid=swg21686479 CONFIRM
http://www-01.ibm.com/support/docview.wss?uid=isg3T1021279 CONFIRM
http://secunia.com/advisories/61287
SECUNIA 61287
http://www-01.ibm.com/support/docview.wss?uid=ssg1S1004879 CONFIRM
http://secunia.com/advisories/61128
SECUNIA 61128
http://secunia.com/advisories/61313
SECUNIA 61313
https://support.citrix.com/article/CTX200217 CONFIRM
http://secunia.com/advisories/61312
SECUNIA 61312
https://support.apple.com/kb/HT6535 CONFIRM
http://secunia.com/advisories/60947
SECUNIA 60947
http://www-01.ibm.com/support/docview.wss?uid=swg21686084 CONFIRM
http://lists.opensuse.org/opensuse-security-announce/2014-10/msg00004.html
SUSE SUSE-SU-2014:1287
http://packetstormsecurity.com/files/128517/VMware-Security-Advisory-2014-0010.html
http://www.oracle.com/technetwork/topics/security/bashcve-2014-7169-2317675.html CONFIRM
http://secunia.com/advisories/61703
SECUNIA 61703
http://seclists.org/fulldisclosure/2014/Oct/0
FULLDISC 20141001 FW: NEW VMSA-2014-0010 - VMware product updates address critical Bash security vulnerabilities
http://www-01.ibm.com/support/docview.wss?uid=swg21685914 CONFIRM
http://www.vmware.com/security/advisories/VMSA-2014-0010.html CONFIRM
http://secunia.com/advisories/61603
SECUNIA 61603
http://www-01.ibm.com/support/docview.wss?uid=isg3T1021272 CONFIRM
http://secunia.com/advisories/61283
SECUNIA 61283
http://marc.info/?l=bugtraq&m=141319209015420&w=2
HP HPSBST03122
http://secunia.com/advisories/61633
SECUNIA 61633
http://secunia.com/advisories/61552
SECUNIA 61552
http://secunia.com/advisories/61643
SECUNIA 61643
https://kb.juniper.net/InfoCenter/index?page=content&id=JSA10648 CONFIRM
http://marc.info/?l=bugtraq&m=141235957116749&w=2
HP HPSBHF03124
http://secunia.com/advisories/61565
SECUNIA 61565
http://packetstormsecurity.com/files/128567/CA-Technologies-GNU-Bash-Shellshock.html
http://secunia.com/advisories/59907
SECUNIA 59907
http://secunia.com/advisories/61654
SECUNIA 61654
http://www-01.ibm.com/support/docview.wss?uid=swg21685749 CONFIRM
http://secunia.com/advisories/61485
SECUNIA 61485
http://lists.opensuse.org/opensuse-security-announce/2014-09/msg00048.html
SUSE SUSE-SU-2014:1259
http://lists.opensuse.org/opensuse-security-announce/2014-09/msg00044.html
SUSE openSUSE-SU-2014:1254
http://marc.info/?l=bugtraq&m=141216668515282&w=2
HP HPSBHF03119
http://rhn.redhat.com/errata/RHSA-2014-1312.html
REDHAT RHSA-2014:1312
http://marc.info/?l=bugtraq&m=141216207813411&w=2
HP HPSBGN03117
http://lists.opensuse.org/opensuse-security-announce/2014-09/msg00041.html
SUSE openSUSE-SU-2014:1242
http://lists.opensuse.org/opensuse-security-announce/2014-09/msg00038.html
SUSE openSUSE-SU-2014:1229
http://secunia.com/advisories/61479
SECUNIA 61479
http://secunia.com/advisories/61619
SECUNIA 61619
http://lists.opensuse.org/opensuse-security-announce/2014-09/msg00042.html
SUSE SUSE-SU-2014:1247
http://rhn.redhat.com/errata/RHSA-2014-1311.html
REDHAT RHSA-2014:1311
http://linux.oracle.com/errata/ELSA-2014-3078.html CONFIRM
http://support.novell.com/security/cve/CVE-2014-7169.html CONFIRM
http://secunia.com/advisories/61622
SECUNIA 61622
http://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20140926-bash
CISCO 20140926 GNU Bash Environmental Variable Command Injection Vulnerability
http://linux.oracle.com/errata/ELSA-2014-3075.html CONFIRM
http://secunia.com/advisories/61641
SECUNIA 61641
http://secunia.com/advisories/59737
SECUNIA 59737
http://secunia.com/advisories/61626
SECUNIA 61626
http://support.apple.com/kb/HT6495 CONFIRM
https://kb.bluecoat.com/index?page=content&id=SA82 CONFIRM
http://www.kb.cert.org/vuls/id/252743
CERT-VN VU#252743
http://www.ubuntu.com/usn/USN-2363-2
UBUNTU USN-2363-2
http://rhn.redhat.com/errata/RHSA-2014-1306.html
REDHAT RHSA-2014:1306
https://www.suse.com/support/shellshock/ CONFIRM
http://www.debian.org/security/2014/dsa-3035
DEBIAN DSA-3035
http://www.us-cert.gov/ncas/alerts/TA14-268A
CERT TA14-268A
http://www.ubuntu.com/usn/USN-2363-1
UBUNTU USN-2363-1
http://lcamtuf.blogspot.com/2014/09/quick-notes-about-bash-bug-its-impact.html
http://twitter.com/taviso/statuses/514887394294652929
http://www.openwall.com/lists/oss-security/2014/09/24/32
MLIST [oss-security] 20140924 Re: CVE-2014-6271: remote code execution through bash

- Metasploit Modules Related To CVE-2014-7169

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.