CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
  Take a third party risk management course for FREE
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2012-1182

The RPC code generator in Samba 3.x before 3.4.16, 3.5.x before 3.5.14, and 3.6.x before 3.6.4 does not implement validation of an array length in a manner consistent with validation of array memory allocation, which allows remote attackers to execute arbitrary code via a crafted RPC call.
Publish Date : 2012-04-10 Last Update Date : 2018-10-30
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
10.0
Confidentiality Impact Complete (There is total information disclosure, resulting in all system files being revealed.)
Integrity Impact Complete (There is a total compromise of system integrity. There is a complete loss of system protection, resulting in the entire system being compromised.)
Availability Impact Complete (There is a total shutdown of the affected resource. The attacker can render the resource completely unavailable.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Execute Code
CWE ID 189

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat critical
8.3
AV:A/AC:L/Au:N/C:C/I:C/A:C 2012-03-16 2012-04-10
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @ cvedetails.com

- Related OVAL Definitions

Title Definition Id Class Family
DEPRECATED: ELSA-2012-0465 -- samba security update (critical) oval:org.mitre.oval:def:27521 unix
DEPRECATED: ELSA-2012-0466 -- samba3x security update (critical) oval:org.mitre.oval:def:27814 unix
DEPRECATED: ELSA-2013-0515 -- openchange security, bug fix and enhancement update (moderate) oval:org.mitre.oval:def:27693 unix
DEPRECATED: ELSA-2013-0506 -- samba4 security, bug fix and enhancement update (moderate) oval:org.mitre.oval:def:26936 unix
DEPRECATED: ELSA-2012:0465: samba security update (Critical) oval:org.mitre.oval:def:23318 unix
DSA-2450-1 samba - privilege escalation oval:org.mitre.oval:def:19714 unix
ELSA-2012:0465: samba security update (Critical) oval:org.mitre.oval:def:23647 unix
ELSA-2012:0466: samba3x security update (Critical) oval:org.mitre.oval:def:23143 unix
ELSA-2013:0506: samba4 security, bug fix and enhancement update (Moderate) oval:org.mitre.oval:def:23742 unix
ELSA-2013:0515: openchange security, bug fix and enhancement update (Moderate) oval:org.mitre.oval:def:24092 unix
HP-UX CIFS Server (Samba), Remote Execution of Arbitrary Code, Elevation of Privileges oval:org.mitre.oval:def:19174 unix
RHSA-2012:0465: samba security update (Critical) oval:org.mitre.oval:def:21345 unix
RHSA-2012:0465: samba security update (Critical) oval:com.redhat.rhsa:def:20120465 unix
RHSA-2012:0466: samba3x security update (Critical) oval:org.mitre.oval:def:21396 unix
RHSA-2012:0466: samba3x security update (Critical) oval:com.redhat.rhsa:def:20120466 unix
RHSA-2013:0506: samba4 security, bug fix and enhancement update (Moderate) oval:org.mitre.oval:def:21003 unix
RHSA-2013:0506: samba4 security, bug fix and enhancement update (Moderate) oval:com.redhat.rhsa:def:20130506 unix
RHSA-2013:0515: openchange security, bug fix and enhancement update (Moderate) oval:org.mitre.oval:def:21042 unix
RHSA-2013:0515: openchange security, bug fix and enhancement update (Moderate) oval:com.redhat.rhsa:def:20130515 unix
USN-1423-1 -- samba vulnerability oval:org.mitre.oval:def:17426 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2012-1182

# Product Type Vendor Product Version Update Edition Language
1 Application Samba Samba * * * * Version Details Vulnerabilities
2 Application Samba Samba 3.0.0 * * * Version Details Vulnerabilities
3 Application Samba Samba 3.0.1 * * * Version Details Vulnerabilities
4 Application Samba Samba 3.0.2 A * * Version Details Vulnerabilities
5 Application Samba Samba 3.0.2 * * * Version Details Vulnerabilities
6 Application Samba Samba 3.0.2a * * * Version Details Vulnerabilities
7 Application Samba Samba 3.0.3 * * * Version Details Vulnerabilities
8 Application Samba Samba 3.0.4 * * * Version Details Vulnerabilities
9 Application Samba Samba 3.0.4 RC1 * * Version Details Vulnerabilities
10 Application Samba Samba 3.0.5 * * * Version Details Vulnerabilities
11 Application Samba Samba 3.0.6 * * * Version Details Vulnerabilities
12 Application Samba Samba 3.0.7 * * * Version Details Vulnerabilities
13 Application Samba Samba 3.0.8 * * * Version Details Vulnerabilities
14 Application Samba Samba 3.0.9 * * * Version Details Vulnerabilities
15 Application Samba Samba 3.0.10 * * * Version Details Vulnerabilities
16 Application Samba Samba 3.0.11 * * * Version Details Vulnerabilities
17 Application Samba Samba 3.0.12 * * * Version Details Vulnerabilities
18 Application Samba Samba 3.0.13 * * * Version Details Vulnerabilities
19 Application Samba Samba 3.0.14 * * * Version Details Vulnerabilities
20 Application Samba Samba 3.0.14a * * * Version Details Vulnerabilities
21 Application Samba Samba 3.0.14 A * * Version Details Vulnerabilities
22 Application Samba Samba 3.0.15 * * * Version Details Vulnerabilities
23 Application Samba Samba 3.0.16 * * * Version Details Vulnerabilities
24 Application Samba Samba 3.0.17 * * * Version Details Vulnerabilities
25 Application Samba Samba 3.0.18 * * * Version Details Vulnerabilities
26 Application Samba Samba 3.0.19 * * * Version Details Vulnerabilities
27 Application Samba Samba 3.0.20 B * * Version Details Vulnerabilities
28 Application Samba Samba 3.0.20 * * * Version Details Vulnerabilities
29 Application Samba Samba 3.0.20a * * * Version Details Vulnerabilities
30 Application Samba Samba 3.0.20b * * * Version Details Vulnerabilities
31 Application Samba Samba 3.0.20 A * * Version Details Vulnerabilities
32 Application Samba Samba 3.0.21 * * * Version Details Vulnerabilities
33 Application Samba Samba 3.0.21a * * * Version Details Vulnerabilities
34 Application Samba Samba 3.0.21b * * * Version Details Vulnerabilities
35 Application Samba Samba 3.0.21 C * * Version Details Vulnerabilities
36 Application Samba Samba 3.0.21c * * * Version Details Vulnerabilities
37 Application Samba Samba 3.0.21 A * * Version Details Vulnerabilities
38 Application Samba Samba 3.0.21 B * * Version Details Vulnerabilities
39 Application Samba Samba 3.0.22 * * * Version Details Vulnerabilities
40 Application Samba Samba 3.0.23 * * * Version Details Vulnerabilities
41 Application Samba Samba 3.0.23c * * * Version Details Vulnerabilities
42 Application Samba Samba 3.0.23d * * * Version Details Vulnerabilities
43 Application Samba Samba 3.0.23a * * * Version Details Vulnerabilities
44 Application Samba Samba 3.0.23 D * * Version Details Vulnerabilities
45 Application Samba Samba 3.0.23 A * * Version Details Vulnerabilities
46 Application Samba Samba 3.0.23 C * * Version Details Vulnerabilities
47 Application Samba Samba 3.0.23 B * * Version Details Vulnerabilities
48 Application Samba Samba 3.0.23b * * * Version Details Vulnerabilities
49 Application Samba Samba 3.0.24 * * * Version Details Vulnerabilities
50 Application Samba Samba 3.0.25a * * * Version Details Vulnerabilities
51 Application Samba Samba 3.0.25 RC2 * * Version Details Vulnerabilities
52 Application Samba Samba 3.0.25 Pre2 * * Version Details Vulnerabilities
53 Application Samba Samba 3.0.25 * * * Version Details Vulnerabilities
54 Application Samba Samba 3.0.25 B * * Version Details Vulnerabilities
55 Application Samba Samba 3.0.25c * * * Version Details Vulnerabilities
56 Application Samba Samba 3.0.25b * * * Version Details Vulnerabilities
57 Application Samba Samba 3.0.25 A * * Version Details Vulnerabilities
58 Application Samba Samba 3.0.25 C * * Version Details Vulnerabilities
59 Application Samba Samba 3.0.25 RC1 * * Version Details Vulnerabilities
60 Application Samba Samba 3.0.25 RC3 * * Version Details Vulnerabilities
61 Application Samba Samba 3.0.25 Pre1 * * Version Details Vulnerabilities
62 Application Samba Samba 3.0.26a * * * Version Details Vulnerabilities
63 Application Samba Samba 3.0.26 A * * Version Details Vulnerabilities
64 Application Samba Samba 3.0.26 * * * Version Details Vulnerabilities
65 Application Samba Samba 3.0.27 * * * Version Details Vulnerabilities
66 Application Samba Samba 3.0.27 A * * Version Details Vulnerabilities
67 Application Samba Samba 3.0.28 * * * Version Details Vulnerabilities
68 Application Samba Samba 3.0.28 A * * Version Details Vulnerabilities
69 Application Samba Samba 3.0.29 * * * Version Details Vulnerabilities
70 Application Samba Samba 3.0.30 * * * Version Details Vulnerabilities
71 Application Samba Samba 3.0.31 * * * Version Details Vulnerabilities
72 Application Samba Samba 3.0.32 * * * Version Details Vulnerabilities
73 Application Samba Samba 3.0.33 * * * Version Details Vulnerabilities
74 Application Samba Samba 3.0.34 * * * Version Details Vulnerabilities
75 Application Samba Samba 3.0.35 * * * Version Details Vulnerabilities
76 Application Samba Samba 3.0.36 * * * Version Details Vulnerabilities
77 Application Samba Samba 3.0.37 * * * Version Details Vulnerabilities
78 Application Samba Samba 3.1.0 * * * Version Details Vulnerabilities
79 Application Samba Samba 3.2.0 * * * Version Details Vulnerabilities
80 Application Samba Samba 3.2.1 * * * Version Details Vulnerabilities
81 Application Samba Samba 3.2.2 * * * Version Details Vulnerabilities
82 Application Samba Samba 3.2.3 * * * Version Details Vulnerabilities
83 Application Samba Samba 3.2.4 * * * Version Details Vulnerabilities
84 Application Samba Samba 3.2.5 * * * Version Details Vulnerabilities
85 Application Samba Samba 3.2.6 * * * Version Details Vulnerabilities
86 Application Samba Samba 3.2.7 * * * Version Details Vulnerabilities
87 Application Samba Samba 3.2.8 * * * Version Details Vulnerabilities
88 Application Samba Samba 3.2.9 * * * Version Details Vulnerabilities
89 Application Samba Samba 3.2.10 * * * Version Details Vulnerabilities
90 Application Samba Samba 3.2.11 * * * Version Details Vulnerabilities
91 Application Samba Samba 3.2.12 * * * Version Details Vulnerabilities
92 Application Samba Samba 3.2.13 * * * Version Details Vulnerabilities
93 Application Samba Samba 3.2.14 * * * Version Details Vulnerabilities
94 Application Samba Samba 3.2.15 * * * Version Details Vulnerabilities
95 Application Samba Samba 3.3.0 * * * Version Details Vulnerabilities
96 Application Samba Samba 3.3.1 * * * Version Details Vulnerabilities
97 Application Samba Samba 3.3.2 * * * Version Details Vulnerabilities
98 Application Samba Samba 3.3.3 * * * Version Details Vulnerabilities
99 Application Samba Samba 3.3.4 * * * Version Details Vulnerabilities
100 Application Samba Samba 3.3.5 * * * Version Details Vulnerabilities
101 Application Samba Samba 3.3.6 * * * Version Details Vulnerabilities
102 Application Samba Samba 3.3.7 * * * Version Details Vulnerabilities
103 Application Samba Samba 3.3.8 * * * Version Details Vulnerabilities
104 Application Samba Samba 3.3.9 * * * Version Details Vulnerabilities
105 Application Samba Samba 3.3.10 * * * Version Details Vulnerabilities
106 Application Samba Samba 3.3.11 * * * Version Details Vulnerabilities
107 Application Samba Samba 3.3.12 * * * Version Details Vulnerabilities
108 Application Samba Samba 3.3.13 * * * Version Details Vulnerabilities
109 Application Samba Samba 3.3.14 * * * Version Details Vulnerabilities
110 Application Samba Samba 3.3.15 * * * Version Details Vulnerabilities
111 Application Samba Samba 3.3.16 * * * Version Details Vulnerabilities
112 Application Samba Samba 3.4.0 * * * Version Details Vulnerabilities
113 Application Samba Samba 3.4.1 * * * Version Details Vulnerabilities
114 Application Samba Samba 3.4.2 * * * Version Details Vulnerabilities
115 Application Samba Samba 3.4.3 * * * Version Details Vulnerabilities
116 Application Samba Samba 3.4.4 * * * Version Details Vulnerabilities
117 Application Samba Samba 3.4.5 * * * Version Details Vulnerabilities
118 Application Samba Samba 3.4.6 * * * Version Details Vulnerabilities
119 Application Samba Samba 3.4.7 * * * Version Details Vulnerabilities
120 Application Samba Samba 3.4.8 * * * Version Details Vulnerabilities
121 Application Samba Samba 3.4.9 * * * Version Details Vulnerabilities
122 Application Samba Samba 3.4.10 * * * Version Details Vulnerabilities
123 Application Samba Samba 3.4.11 * * * Version Details Vulnerabilities
124 Application Samba Samba 3.4.12 * * * Version Details Vulnerabilities
125 Application Samba Samba 3.4.13 * * * Version Details Vulnerabilities
126 Application Samba Samba 3.4.14 * * * Version Details Vulnerabilities
127 Application Samba Samba 3.5.0 * * * Version Details Vulnerabilities
128 Application Samba Samba 3.5.1 * * * Version Details Vulnerabilities
129 Application Samba Samba 3.5.2 * * * Version Details Vulnerabilities
130 Application Samba Samba 3.5.3 * * * Version Details Vulnerabilities
131 Application Samba Samba 3.5.4 * * * Version Details Vulnerabilities
132 Application Samba Samba 3.5.5 * * * Version Details Vulnerabilities
133 Application Samba Samba 3.5.6 * * * Version Details Vulnerabilities
134 Application Samba Samba 3.5.7 * * * Version Details Vulnerabilities
135 Application Samba Samba 3.5.8 * * * Version Details Vulnerabilities
136 Application Samba Samba 3.5.9 * * * Version Details Vulnerabilities
137 Application Samba Samba 3.5.10 * * * Version Details Vulnerabilities
138 Application Samba Samba 3.5.11 * * * Version Details Vulnerabilities
139 Application Samba Samba 3.5.12 * * * Version Details Vulnerabilities
140 Application Samba Samba 3.5.13 * * * Version Details Vulnerabilities
141 Application Samba Samba 3.6.0 * * * Version Details Vulnerabilities
142 Application Samba Samba 3.6.1 * * * Version Details Vulnerabilities
143 Application Samba Samba 3.6.2 * * * Version Details Vulnerabilities
144 Application Samba Samba 3.6.3 * * * Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Samba Samba 144

- References For CVE-2012-1182

http://marc.info/?l=bugtraq&m=134323086902585&w=2
HP SSRT100824
http://lists.fedoraproject.org/pipermail/package-announce/2012-April/078726.html
FEDORA FEDORA-2012-5793
http://lists.fedoraproject.org/pipermail/package-announce/2012-April/078258.html
FEDORA FEDORA-2012-5843
https://www.samba.org/samba/security/CVE-2012-1182 CONFIRM
http://support.apple.com/kb/HT5281 CONFIRM
http://lists.apple.com/archives/security-announce/2012/May/msg00001.html
APPLE APPLE-SA-2012-05-09-1
http://www.securitytracker.com/id?1026913
SECTRACK 1026913
http://lists.fedoraproject.org/pipermail/package-announce/2012-April/078836.html
FEDORA FEDORA-2012-5805
http://www.samba.org/samba/history/samba-3.6.4.html CONFIRM
http://marc.info/?l=bugtraq&m=133951282306605&w=2
HP SSRT100872
http://secunia.com/advisories/48873
SECUNIA 48873
http://secunia.com/advisories/48751
SECUNIA 48751
http://secunia.com/advisories/48754
SECUNIA 48754
http://www.ubuntu.com/usn/USN-1423-1
UBUNTU USN-1423-1
http://secunia.com/advisories/48844
SECUNIA 48844
http://secunia.com/advisories/48818
SECUNIA 48818
http://secunia.com/advisories/48879
SECUNIA 48879
http://secunia.com/advisories/48816
SECUNIA 48816
http://secunia.com/advisories/48999
SECUNIA 48999
http://lists.fedoraproject.org/pipermail/package-announce/2012-May/080567.html
FEDORA FEDORA-2012-6382
http://www.collax.com/produkte/AllinOne-server-for-small-businesses#id2565578 CONFIRM
http://www.debian.org/security/2012/dsa-2450
DEBIAN DSA-2450
http://www.mandriva.com/security/advisories?name=MDVSA-2012:055
MANDRIVA MDVSA-2012:055
http://lists.opensuse.org/opensuse-security-announce/2012-04/msg00014.html
SUSE SUSE-SU-2012:0515
http://lists.opensuse.org/opensuse-security-announce/2012-04/msg00009.html
SUSE SUSE-SU-2012:0504
http://lists.opensuse.org/opensuse-security-announce/2012-04/msg00008.html
SUSE SUSE-SU-2012:0502
http://lists.opensuse.org/opensuse-security-announce/2012-04/msg00007.html
SUSE SUSE-SU-2012:0501

- Metasploit Modules Related To CVE-2012-1182

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.