CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
  Take a third party risk management course for FREE
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2012-0442

Multiple unspecified vulnerabilities in the browser engine in Mozilla Firefox before 3.6.26 and 4.x through 9.0, Thunderbird before 3.1.18 and 5.0 through 9.0, and SeaMonkey before 2.7 allow remote attackers to cause a denial of service (memory corruption and application crash) or possibly execute arbitrary code via unknown vectors.
Publish Date : 2012-02-01 Last Update Date : 2020-08-28
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
9.3
Confidentiality Impact Complete (There is total information disclosure, resulting in all system files being revealed.)
Integrity Impact Complete (There is a total compromise of system integrity. There is a complete loss of system protection, resulting in the entire system being compromised.)
Availability Impact Complete (There is a total shutdown of the affected resource. The attacker can render the resource completely unavailable.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Denial Of ServiceExecute CodeMemory corruption
CWE ID CWE id is not defined for this vulnerability

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat critical
6.8
AV:N/AC:M/Au:N/C:P/I:P/A:P 2012-01-27 2012-01-31
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @ cvedetails.com

- Related OVAL Definitions

Title Definition Id Class Family
CVE-2012-0442 oval:org.opensuse.security:def:20120442 unix
DEPRECATED: ELSA-2012:0079: firefox security update (Critical) oval:org.mitre.oval:def:23338 unix
DEPRECATED: ELSA-2012-0080 -- thunderbird security update (critical) oval:org.mitre.oval:def:27597 unix
DSA-2400-1 iceweasel -- several oval:org.mitre.oval:def:14983 unix
DSA-2402-1 iceape -- several oval:org.mitre.oval:def:15283 unix
DSA-2406-1 icedove -- several oval:org.mitre.oval:def:14959 unix
ELSA-2012:0079: firefox security update (Critical) oval:org.mitre.oval:def:23504 unix
ELSA-2012:0080: thunderbird security update (Critical) oval:org.mitre.oval:def:23792 unix
ELSA-2012:0085: thunderbird security update (Critical) oval:org.mitre.oval:def:22851 unix
Multiple unspecified vulnerabilities in the browser engine in Mozilla Firefox before 3.6.26 and 4.x through 9.0, Thunder... oval:org.mitre.oval:def:14678 windows
RHSA-2012:0079: firefox security update (Critical) oval:org.mitre.oval:def:20719 unix
RHSA-2012:0079: firefox security update (Critical) oval:com.redhat.rhsa:def:20120079 unix
RHSA-2012:0080: thunderbird security update (Critical) oval:org.mitre.oval:def:20845 unix
RHSA-2012:0080: thunderbird security update (Critical) oval:com.redhat.rhsa:def:20120080 unix
RHSA-2012:0084: seamonkey security update (Critical) oval:com.redhat.rhsa:def:20120084 unix
RHSA-2012:0085: thunderbird security update (Critical) oval:com.redhat.rhsa:def:20120085 unix
RHSA-2012:0085: thunderbird security update (Critical) oval:org.mitre.oval:def:21230 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2012-0442

# Product Type Vendor Product Version Update Edition Language
1 OS Debian Debian Linux 5.0 * * * Version Details Vulnerabilities
2 OS Debian Debian Linux 6.0 * * * Version Details Vulnerabilities
3 Application Mozilla Firefox * * * * Version Details Vulnerabilities
4 Application Mozilla Seamonkey * * * * Version Details Vulnerabilities
5 Application Mozilla Thunderbird * * * * Version Details Vulnerabilities
6 OS Opensuse Opensuse 11.4 * * * Version Details Vulnerabilities
7 OS Suse Linux Enterprise Desktop 10 SP4 * * Version Details Vulnerabilities
8 OS Suse Linux Enterprise Desktop 11 SP1 * * Version Details Vulnerabilities
9 OS Suse Linux Enterprise Server 10 SP4 * * Version Details Vulnerabilities
10 OS Suse Linux Enterprise Server 11 SP1 * * Version Details Vulnerabilities
11 OS Suse Linux Enterprise Server 11 SP1 * * Version Details Vulnerabilities
12 OS Suse Linux Enterprise Software Development Kit 10 SP4 * * Version Details Vulnerabilities
13 OS Suse Linux Enterprise Software Development Kit 11 SP1 * * Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Debian Debian Linux 2
Mozilla Firefox 1
Mozilla Seamonkey 1
Mozilla Thunderbird 1
Opensuse Opensuse 1
Suse Linux Enterprise Desktop 2
Suse Linux Enterprise Server 3
Suse Linux Enterprise Software Development Kit 2

- References For CVE-2012-0442

http://www.mandriva.com/security/advisories?name=MDVSA-2012:013
MANDRIVA MDVSA-2012:013
https://bugzilla.mozilla.org/show_bug.cgi?id=705347 CONFIRM
http://lists.opensuse.org/opensuse-security-announce/2012-02/msg00007.html
SUSE SUSE-SU-2012:0221
http://lists.opensuse.org/opensuse-security-announce/2012-02/msg00003.html
SUSE SUSE-SU-2012:0198
http://lists.opensuse.org/opensuse-security-announce/2012-02/msg00011.html
SUSE openSUSE-SU-2012:0234
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A14678
OVAL oval:org.mitre.oval:def:14678
http://www.debian.org/security/2012/dsa-2400
DEBIAN DSA-2400
http://www.mozilla.org/security/announce/2012/mfsa2012-01.html CONFIRM
https://bugzilla.mozilla.org/show_bug.cgi?id=693399 CONFIRM
http://www.debian.org/security/2012/dsa-2406
DEBIAN DSA-2406
http://www.debian.org/security/2012/dsa-2402
DEBIAN DSA-2402

- Metasploit Modules Related To CVE-2012-0442

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.