CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
  Take a third party risk management course for FREE
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2006-5276

Stack-based buffer overflow in the DCE/RPC preprocessor in Snort before 2.6.1.3, and 2.7 before beta 2; and Sourcefire Intrusion Sensor; allows remote attackers to execute arbitrary code via crafted SMB traffic.
Publish Date : 2007-02-20 Last Update Date : 2018-10-17
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
10.0
Confidentiality Impact Complete (There is total information disclosure, resulting in all system files being revealed.)
Integrity Impact Complete (There is a total compromise of system integrity. There is a complete loss of system protection, resulting in the entire system being compromised.)
Availability Impact Complete (There is a total shutdown of the affected resource. The attacker can render the resource completely unavailable.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Execute CodeOverflow
CWE ID CWE id is not defined for this vulnerability

- Products Affected By CVE-2006-5276

# Product Type Vendor Product Version Update Edition Language
1 Application Snort Snort * * * * Version Details Vulnerabilities
2 Application Snort Snort 2.6.1 * * * Version Details Vulnerabilities
3 Application Snort Snort 2.6.1.1 * * * Version Details Vulnerabilities
4 Application Snort Snort 2.7 Beta1 * * * Version Details Vulnerabilities
5 Application Sourcefire Intrusion Sensor 4.1 * * * Version Details Vulnerabilities
6 Application Sourcefire Intrusion Sensor 4.1 * Crossbeam * Version Details Vulnerabilities
7 Application Sourcefire Intrusion Sensor 4.5 * * * Version Details Vulnerabilities
8 Application Sourcefire Intrusion Sensor 4.5 * Crossbeam * Version Details Vulnerabilities
9 Application Sourcefire Intrusion Sensor 4.6 * Crossbeam * Version Details Vulnerabilities
10 Application Sourcefire Intrusion Sensor 4.6 * * * Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Snort Snort 4
Sourcefire Intrusion Sensor 6

- References For CVE-2006-5276

http://www.securityfocus.com/bid/22616
BID 22616 Snort/Sourcefire DCE/RPC Packet Reassembly Stack Buffer Overflow Vulnerability Release Date:2007-11-15
http://www.kb.cert.org/vuls/id/196240
CERT-VN VU#196240
http://fedoranews.org/updates/FEDORA-2007-206.shtml
FEDORA FEDORA-2007-2060
http://secunia.com/advisories/24272
SECUNIA 24272
https://bugzilla.redhat.com/show_bug.cgi?id=229265
http://secunia.com/advisories/24235
SECUNIA 24235
http://secunia.com/advisories/24239
SECUNIA 24239
http://secunia.com/advisories/24240
SECUNIA 24240
http://secunia.com/advisories/24190
SECUNIA 24190
http://www.securitytracker.com/id?1017670
SECTRACK 1017670
http://security.gentoo.org/glsa/glsa-200703-01.xml
GENTOO GLSA-200703-01
http://www.osvdb.org/32094
OSVDB 32094
http://www.securitytracker.com/id?1017669
SECTRACK 1017669
http://www130.nortelnetworks.com/go/main.jsp?cscat=BLTNDETAIL&DocumentOID=540173 CONFIRM
http://www.us-cert.gov/cas/techalerts/TA07-050A.html
CERT TA07-050A
http://www116.nortelnetworks.com/pub/repository/CLARIFY/DOCUMENT/2007/08/021923-01.pdf CONFIRM
http://www.snort.org/docs/advisory-2007-02-19.html CONFIRM
http://iss.net/threats/257.html
ISS 20070219 Sourcefire Snort Remote Buffer Overflow
http://secunia.com/advisories/26746
SECUNIA 26746
http://www.vupen.com/english/advisories/2007/0668
VUPEN ADV-2007-0668
http://www.vupen.com/english/advisories/2007/0656
VUPEN ADV-2007-0656
https://exchange.xforce.ibmcloud.com/vulnerabilities/31275
XF smb-bo(31275)
https://www.exploit-db.com/exploits/3362
EXPLOIT-DB 3362
http://www.securityfocus.com/archive/1/461810/100/0/threaded
BUGTRAQ 20070303 ERRATA: [ GLSA 200703-01 ] Snort: Remote execution of arbitrary code

- Metasploit Modules Related To CVE-2006-5276

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.