CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
  Take a third party risk management course for FREE
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2005-3274

Race condition in ip_vs_conn_flush in Linux 2.6 before 2.6.13 and 2.4 before 2.4.32-pre2, when running on SMP systems, allows local users to cause a denial of service (null dereference) by causing a connection timer to expire while the connection table is being flushed before the appropriate lock is acquired.
Publish Date : 2005-10-21 Last Update Date : 2018-10-19
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
1.2
Confidentiality Impact None (There is no impact to the confidentiality of the system.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity High (Specialized access conditions exist. It is hard to exploit and several special conditions must be satisfied to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Denial Of Service
CWE ID CWE id is not defined for this vulnerability

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat important 2005-06-28 2005-06-28
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @ cvedetails.com

- Related OVAL Definitions

Title Definition Id Class Family
Race condition in ip_vs_conn_flush in Linux 2.6 before 2.6.13 and 2.4 before 2.4.32-pre2, when running on SMP systems, a... oval:org.mitre.oval:def:11723 unix
RHSA-2005:514: Updated kernel packages available for Red Hat Enterprise Linux 4 Update 2 (Important) oval:com.redhat.rhsa:def:20050514 unix
RHSA-2005:514: Updated kernel packages available for Red Hat Enterprise Linux 4 Update 2 (Important) oval:com.redhat.rhsa:def:2005514 unix
RHSA-2005:663: Updated kernel packages available for Red Hat Enterprise Linux 3 Update 6 (Important) oval:com.redhat.rhsa:def:2005663 unix
RHSA-2005:663: Updated kernel packages available for Red Hat Enterprise Linux 3 Update 6 (Important) oval:com.redhat.rhsa:def:20050663 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2005-3274

# Product Type Vendor Product Version Update Edition Language
1 OS Linux Linux Kernel 2.4.0 * * * Version Details Vulnerabilities
2 OS Linux Linux Kernel 2.4.1 * * * Version Details Vulnerabilities
3 OS Linux Linux Kernel 2.4.2 * * * Version Details Vulnerabilities
4 OS Linux Linux Kernel 2.4.3 * * * Version Details Vulnerabilities
5 OS Linux Linux Kernel 2.4.4 * * * Version Details Vulnerabilities
6 OS Linux Linux Kernel 2.4.5 * * * Version Details Vulnerabilities
7 OS Linux Linux Kernel 2.4.6 * * * Version Details Vulnerabilities
8 OS Linux Linux Kernel 2.4.7 * * * Version Details Vulnerabilities
9 OS Linux Linux Kernel 2.4.8 * * * Version Details Vulnerabilities
10 OS Linux Linux Kernel 2.4.9 * * * Version Details Vulnerabilities
11 OS Linux Linux Kernel 2.4.10 * * * Version Details Vulnerabilities
12 OS Linux Linux Kernel 2.4.11 * * * Version Details Vulnerabilities
13 OS Linux Linux Kernel 2.4.12 * * * Version Details Vulnerabilities
14 OS Linux Linux Kernel 2.4.13 * * * Version Details Vulnerabilities
15 OS Linux Linux Kernel 2.4.14 * * * Version Details Vulnerabilities
16 OS Linux Linux Kernel 2.4.15 * * * Version Details Vulnerabilities
17 OS Linux Linux Kernel 2.4.16 * * * Version Details Vulnerabilities
18 OS Linux Linux Kernel 2.4.17 * * * Version Details Vulnerabilities
19 OS Linux Linux Kernel 2.4.18 * * * Version Details Vulnerabilities
20 OS Linux Linux Kernel 2.4.19 * * * Version Details Vulnerabilities
21 OS Linux Linux Kernel 2.4.20 * * * Version Details Vulnerabilities
22 OS Linux Linux Kernel 2.4.21 * * * Version Details Vulnerabilities
23 OS Linux Linux Kernel 2.4.22 * * * Version Details Vulnerabilities
24 OS Linux Linux Kernel 2.4.23 * * * Version Details Vulnerabilities
25 OS Linux Linux Kernel 2.4.24 * * * Version Details Vulnerabilities
26 OS Linux Linux Kernel 2.4.25 * * * Version Details Vulnerabilities
27 OS Linux Linux Kernel 2.4.26 * * * Version Details Vulnerabilities
28 OS Linux Linux Kernel 2.4.27 * * * Version Details Vulnerabilities
29 OS Linux Linux Kernel 2.4.28 * * * Version Details Vulnerabilities
30 OS Linux Linux Kernel 2.4.29 * * * Version Details Vulnerabilities
31 OS Linux Linux Kernel 2.4.30 * * * Version Details Vulnerabilities
32 OS Linux Linux Kernel 2.4.31 * * * Version Details Vulnerabilities
33 OS Linux Linux Kernel 2.6.0 * * * Version Details Vulnerabilities
34 OS Linux Linux Kernel 2.6.1 * * * Version Details Vulnerabilities
35 OS Linux Linux Kernel 2.6.2 * * * Version Details Vulnerabilities
36 OS Linux Linux Kernel 2.6.3 * * * Version Details Vulnerabilities
37 OS Linux Linux Kernel 2.6.4 * * * Version Details Vulnerabilities
38 OS Linux Linux Kernel 2.6.5 * * * Version Details Vulnerabilities
39 OS Linux Linux Kernel 2.6.6 * * * Version Details Vulnerabilities
40 OS Linux Linux Kernel 2.6.7 * * * Version Details Vulnerabilities
41 OS Linux Linux Kernel 2.6.8 * * * Version Details Vulnerabilities
42 OS Linux Linux Kernel 2.6.8.1 * * * Version Details Vulnerabilities
43 OS Linux Linux Kernel 2.6.9 2.6.20 * * Version Details Vulnerabilities
44 OS Linux Linux Kernel 2.6.10 * * * Version Details Vulnerabilities
45 OS Linux Linux Kernel 2.6.11 * * * Version Details Vulnerabilities
46 OS Linux Linux Kernel 2.6.11.1 * * * Version Details Vulnerabilities
47 OS Linux Linux Kernel 2.6.11.2 * * * Version Details Vulnerabilities
48 OS Linux Linux Kernel 2.6.11.3 * * * Version Details Vulnerabilities
49 OS Linux Linux Kernel 2.6.11.4 * * * Version Details Vulnerabilities
50 OS Linux Linux Kernel 2.6.11.5 * * * Version Details Vulnerabilities
51 OS Linux Linux Kernel 2.6.11.6 * * * Version Details Vulnerabilities
52 OS Linux Linux Kernel 2.6.11.7 * * * Version Details Vulnerabilities
53 OS Linux Linux Kernel 2.6.11.8 * * * Version Details Vulnerabilities
54 OS Linux Linux Kernel 2.6.11.9 * * * Version Details Vulnerabilities
55 OS Linux Linux Kernel 2.6.11.10 * * * Version Details Vulnerabilities
56 OS Linux Linux Kernel 2.6.11.11 * * * Version Details Vulnerabilities
57 OS Linux Linux Kernel 2.6.11.12 * * * Version Details Vulnerabilities
58 OS Linux Linux Kernel 2.6.12 * * * Version Details Vulnerabilities
59 OS Linux Linux Kernel 2.6.12.1 * * * Version Details Vulnerabilities
60 OS Linux Linux Kernel 2.6.12.2 * * * Version Details Vulnerabilities
61 OS Linux Linux Kernel 2.6.12.3 * * * Version Details Vulnerabilities
62 OS Linux Linux Kernel 2.6.12.4 * * * Version Details Vulnerabilities
63 OS Linux Linux Kernel 2.6.12.5 * * * Version Details Vulnerabilities
64 OS Linux Linux Kernel 2.6.12.6 * * * Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Linux Linux Kernel 64

- References For CVE-2005-3274

http://www.mandriva.com/security/advisories?name=MDKSA-2005:218
MANDRAKE MDKSA-2005:218
http://lkml.org/lkml/2005/6/23/249 CONFIRM
http://www.redhat.com/support/errata/RHSA-2005-663.html
REDHAT RHSA-2005:663
http://secunia.com/advisories/17826
SECUNIA 17826
http://secunia.com/advisories/18977
SECUNIA 18977
http://secunia.com/advisories/18684
SECUNIA 18684
http://wwwnew.mandriva.com/security/advisories?name=MDKSA-2006:044
MANDRIVA MDKSA-2006:044
http://www.kernel.org/git/?p=linux/kernel/git/marcelo/linux-2.4.git;a=commit;h=e684f066dff5628bb61ad1912de6e8058b5b4c7d CONFIRM
http://www.securityfocus.com/bid/15528
BID 15528 Linux Kernel IP_VS_CONN_FLUSH Local Denial of Service Vulnerability Release Date:2006-12-20
http://www.debian.org/security/2005/dsa-922
DEBIAN DSA-922
http://www.redhat.com/support/errata/RHSA-2006-0190.html
REDHAT RHSA-2006:0190
http://secunia.com/advisories/18056
SECUNIA 18056
http://lkml.org/lkml/2005/6/24/173 CONFIRM
http://www.mandriva.com/security/advisories?name=MDKSA-2005:235
MANDRIVA MDKSA-2005:235
http://www.mandriva.com/security/advisories?name=MDKSA-2005:220
MANDRAKE MDKSA-2005:220
http://www.mandriva.com/security/advisories?name=MDKSA-2005:219
MANDRAKE MDKSA-2005:219
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A11723
OVAL oval:org.mitre.oval:def:11723
https://usn.ubuntu.com/219-1/
UBUNTU USN-219-1
http://www.securityfocus.com/archive/1/427981/100/0/threaded
FEDORA FLSA:157459-4
http://www.securityfocus.com/archive/1/427980/100/0/threaded
FEDORA FLSA:157459-3

- Metasploit Modules Related To CVE-2005-3274

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.